Montego Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic
Author Message
fyb3roptik
Newbie
Newbie



Joined: Apr 27, 2006
Posts: 6

PostPosted: Thu Apr 27, 2006 10:07 pm Reply with quote

Can someone tell me why i am now getting this after installing this product? I login as admin and thats all i see now.....i tried uninstalling it, but i get the same thing. I am running 7.6

EDIT: Ok i found out it has messed up my database.....i had customized it and now my whole site is messed up......thanks a lot for messing it up........now how the hell do i fix it back to normal?
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Thu Apr 27, 2006 11:57 pm Reply with quote

Hang on here! The installer for this will not "mess up" your database. It simply adds three new tables to your nuke database that are used strictly for the HTML Newsletter tool. No-one else is experiencing such a thing as you can see from the very few forums posts, so you need to calm down and lets think this through.

First of all, there were a few very key instructions given to you in the README.txt and NEWINSTALLS.txt files, such as this one:

Quote:

--------------------------------------------------------------------------
THESE INSTRUCTIONS ARE FOR NEW INSTALLATIONS ONLY!!!!
--------------------------------------------------------------------------

1) FIRST (and always) BACKUP YOUR FILES and mySQL Database.



If you took this very good advice, then you should be able to very easily restore your database to its original state...

There is also another very important lines in the installation instructions:

Quote:

--------------------------------------------------------------------------
REQUIREMENTS FOR THIS VERSION:
--------------------------------------------------------------------------

- PHP-Nuke 6.5 - 7.6 (tested on 7.4, 7.5 and 7.6, but believe should work
on the others listed)
- Minimum 2.9 Patchset from Chatserv (tested on 3.1 ONLY)
- Tested on IE 6.0 and Firefox 1.0.7/1.5.0.



The line about requiring the 2.9 patchset or greater is also in bold letters on the download.

Now, to at least get you back to where you can access your admin files. You need to simply delete the following directory (and all files under it):

modules/HTML_Newsletter.

That is it! You may think your database is all messed up, but I believe it is only that your mainfile.php and admin.php and other scripts have not been patched to the right level. That is ALL that is wrong.

If you can calm down and work with me rationally, I will help you as best I can. Try the above first and let me know what happens.

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
fyb3roptik
Newbie
Newbie



Joined: Apr 27, 2006
Posts: 6

PostPosted: Fri Apr 28, 2006 12:29 am Reply with quote

sry....was freaking out.........anyways i deleted that folder and still get that error.....also i had my database set to only show 1 news item on the front page and it shows 10 again......which means the config file was changed...

EDIT: I renamed the folder and that fixed it....for some reason the folder wont delete.....ok so it looks like im back to square 1........what chat patch do i need?


Last edited by fyb3roptik on Fri Apr 28, 2006 1:00 am; edited 1 time in total 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Fri Apr 28, 2006 12:57 am Reply with quote

fyb3roptik wrote:
sry....was freaking out.........anyways i deleted that folder and still get that error.....also i had my database set to only show 1 news item on the front page and it shows 10 again......which means the config file was changed...


I am telling you, my installer did NOT do this. You have made other updates to your database and/or files that are not even related to HTML Newsletter.

Again, look at the forums posts here. No-one else is having these issues. Did you have a completely working and tested nuke installation prior to installing HTML Newsletter and was it at least patched to the 2.9 patchset or greater?

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
fyb3roptik
Newbie
Newbie



Joined: Apr 27, 2006
Posts: 6

PostPosted: Fri Apr 28, 2006 1:01 am Reply with quote

it was a 7.6 install and was working fine....how do i know if the 2.9 patch is on it?
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Fri Apr 28, 2006 1:17 am Reply with quote

fyb3roptik wrote:
EDIT: I renamed the folder and that fixed it....for some reason the folder wont delete.....ok so it looks like im back to square 1........what chat patch do i need?


Ok, good, I see we're back in business! Wink And, I hope the heartrate has come back down a few notches for you. Laughing

The question you ask here and in your post just above, is an "age-old" question that has plauged me for years. I just cannot figure out why Chat never included the version number in his patched files - at least not in a consistent manner. There are threads on http://ravenphpscripts.com which ask the same question.

If you do not recall installing them, there is a high likelihood you are not patched. However, lets at least see if you have them at all. Do this and let me know what you see:

=== OPEN FILE ===

admin.php <-- this is in your root nuke directory

=== FIND ===

define('ADMIN_FILE', true);

===========

Is the above line anywhere close to the top of the script? If not, then you do not have the minimum patch level for sure and may not even be patched at all, but that is just a guess on my part.

You can get the latest patches from http://nukeresources.net (links are on the front of my site here), although, I have to make just a very small small print warning that I have not tested this version on the 3.2 patchsets as yet. If you can find the 3.1 patches there, you might consider installing those instead, but from what I have seen of the 3.2 patches so far, if they cause any issues with the module (doubtful), I should be able to help you work around them.

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
fyb3roptik
Newbie
Newbie



Joined: Apr 27, 2006
Posts: 6

PostPosted: Fri Apr 28, 2006 1:50 am Reply with quote

so i just copy those files over my current ones? what about all the mods ive made to them....isnt there an easier way to patch this? looks like all he has are full nuke installls........although im probably wrong
 
View user's profile Send private message
fyb3roptik
Newbie
Newbie



Joined: Apr 27, 2006
Posts: 6

PostPosted: Fri Apr 28, 2006 2:28 am Reply with quote

ok i updated it, and ran the .sql file update and now im getting mysql errors........as in my site doesnt even come up!!!! what did i do wrong......if i start over with a fresh install and just recopy my theme over, will it all be ok?
 
View user's profile Send private message
Guardian
Site Admin
Site Admin



Joined: Jul 18, 2005
Posts: 397

PostPosted: Fri Apr 28, 2006 6:47 am Reply with quote

I'm not sure of your timezone and I only have a few hours free but if you can PM me your site adress together with your FTP log-in details I can atleast check some files for you.
The installer that Montego includes with his module should not touch anything in your database except for creating three new tables which are completely independant.
What concerns me more at the moment is you say you could not delete the folder which would seem to indicate that something else on your site had changed the folder permissions.
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Fri Apr 28, 2006 7:27 am Reply with quote

Guardian wrote:
What concerns me more at the moment is you say you could not delete the folder which would seem to indicate that something else on your site had changed the folder permissions.


Guardian, thanks for checking in. It was at the end of my day and needed to get to sleep. I am pretty sure the "could not delete the folder" issue was another process had the file open, such as a text editor or I have even had Apache hold a file open at odd times.

Guardian wrote:
what did i do wrong......if i start over with a fresh install and just recopy my theme over, will it all be ok?


A fresh core nuke installation followed by an overwrite of patch files WILL work every time. It is when we have made so many code hacks to our files and try to merge the patches with our own patches that we can make mistakes.

It is difficult to say what the right decision is for you because I do not know if this was already a new installation, an upgrade, if you have 2 users or 20000... you get the idea? If you feel that doing a fresh installation will work for you, I would give serious consideration to the RavenNuke76 distro (latest release is 2.02.02) over at http://ravenphpscripts.com. I say this only because Raven and Team make it very painless to install and to keep up with updates, plus, Raven's site is more geared for general nuke questions such as these. He has far more people helping him out over there and has a wealth of information already in his Forums.

Ok, that aside, you should be able to copy your themes over, however, you may have a few minor problems if your theme was non-patched. However, he has this specific FAQ which covers that issue (which is almost 95% of the problems we see over there):

http://ravenphpscripts.com/faq-2-.html#57

Good luck.

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
fyb3roptik
Newbie
Newbie



Joined: Apr 27, 2006
Posts: 6

PostPosted: Fri Apr 28, 2006 1:07 pm Reply with quote

Yah this is my test site.....so it was only myself as an admin. I have only made changes to the theme, so I figure if i just reinstall it and copy the theme over i can start over.
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Sat Apr 29, 2006 9:53 am Reply with quote

Since this is a fresh install, I would really, really, really strongly recommend getting Raven's RavenNuke76 latest version distribution from http://ravenphpscripts.com as it is painless to install.

Once installed and set up (all with excellent How To Install manual) you should be able to copy over your theme, however, you may need to make very slight adjustments for the higher patch levels. (The FAQ I noted above.)

The HTML Newsletter module has already been independently tested for that distribution AND will be incorporated into it for the next release of RavenNuke76.

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
Display posts from previous:       
Post new topic   Reply to topic

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 4 Hours
 
Forums ©
linear-bunch
linear-bunch
linear-bunch