Montego Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic
Author Message
bf2taz
Newbie
Newbie



Joined: Apr 12, 2006
Posts: 10

PostPosted: Wed Apr 12, 2006 12:27 pm Reply with quote

Total Emails Sent: 21

ERROR IN MODULE: HTML_Newsletter

ERROR MSG: PHP mail function failed - was unable to send newsletter to:

That's all i get, no emails are sent out either Sad

I do have nsn groups turned on and was trying to send to a group. Seems like there must be an error but code is not trapping it? Debug mode is off.

NOTE this is only happening when I try to send to an nsn group, if I just send to people assigned tp the newsletter it works fine. I need to be able to use the nsn groups.
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Thu Apr 13, 2006 1:59 am Reply with quote

Well, the mail function is the same between the two, just who it gets sent to is different. I suspect that user number 22 has something odd with his/her email address. Try turning debug mode back on to VERBOSE, which will not send the emails, but should display them to the page. Can you see anything odd about any of them?

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
bf2taz
Newbie
Newbie



Joined: Apr 12, 2006
Posts: 10

PostPosted: Thu Apr 13, 2006 2:28 am Reply with quote

At the time there were only 21 users in the nsn group. It is the same group of people that I sent to by telling the script to send to the users signed up for the newsletter, I verified that. I'll try to send another nl tomorrow.
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Thu Apr 13, 2006 12:35 pm Reply with quote

I still need you to try it with VERBOSE as the debug mode and tell me if you see all 21 email addresses showing in the list as you would expect. I see the count is 21, which sounds correct, but need to know if the right emails are being pulled back.

I have compared the code and the only difference between NSN Groups and the Subscribed is the SQL that is passed to the function so it pulls back the data. Therefore, I need to know if the list of users and email addresses look right.

Thanks.

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
bf2taz
Newbie
Newbie



Joined: Apr 12, 2006
Posts: 10

PostPosted: Thu Apr 13, 2006 2:25 pm Reply with quote

All right, I'll check it this morning and post my results in this same post.

RESULTS----------


Your not going to belive me, but here is what it did. I took the newsletter I was trying to send out, and tried to have it send out using NSN Groups with my group called Beta Testers. I got this error

Total Emails Sent: 27

ERROR IN MODULE: HTML_Newsletter

ERROR MSG: PHP mail function failed - was unable to send newsletter to:

So I turned right around and sent it out by clicking the option to send out to people who are signed up for the newsletter, which is again 27 accounts, the same accounts that are in the nsn group. It was sent out with no problems.

---------------------------Verbose on-------------------------------------
Top SQL
--------------------------------------------------------------------------
Array ( [debug_mode] => VERBOSE [debug_output] => DISPLAY [show_blocks] => 0 [dl_module] => downloads [blk_lmt] => 10 [scroll] => 1 [scroll_height] => 180 [scroll_amt] => 2 [scroll_delay] => 100 [version] => 01.03.01 [show_hits] => 0 [show_dates] => 0 [show_sender] => 1 [show_categories] => 0 [nsn_groups] => 1 [latest_news] => 0 [latest_downloads] => 0 [latest_links] => 0 [latest_forums] => 0 [latest_reviews] => 0 [wysiwyg_on] => 0 [wysiwyg_rows] => 30 )

SQL = SELECT `config_name`, `config_value` FROM `nuke_bbconfig`

--------------------------------------------------------------------------
middle sql
--------------------------------------------------------------------------
msnl_iView = 4

Array ( [0] => 3 )

msnl_sGroups = 3

msnl_sFFilename = ./modules/HTML_Newsletter/archive/1144941969.php

msnl_sFileTestEmail = ./modules/HTML_Newsletter/archive/testemail.php

msnl_sFilename = 1144941969.php

SQL = SELECT MAX(`nid`) AS nid FROM `nuke_hnl_newsletters`

SQL = SELECT DISTINCT `user_id`, `user_email` FROM `nuke_users` a, `nuke_nsngr_users` b WHERE b.`uid` = a.`user_id` AND `gid` IN ('3') ORDER BY a.`user_id`

Total Emails Sent: 27

<<edited 27 emails - although they were already "cleansed">>

Newsletter emails sent successfully
-------------------------------------------------------------------------
VERBOSE off, SAME EMAIL TEXT
-------------------------------------------------------------------------
Total Emails Sent: 27

ERROR IN MODULE: HTML_Newsletter

ERROR MSG: PHP mail function failed - was unable to send newsletter to:
-------------------------------------------------------------------------
I tried another newsletter with just a very short message like :

<b>THIS IS A TEST NEWSLETTER, TROUBLESHOOTING A PROBLEM, PLEASE DELETE</b>

and still got

Total Emails Sent: 27

ERROR IN MODULE: HTML_Newsletter

ERROR MSG: PHP mail function failed - was unable to send newsletter to:

So I am going to try deleting the group, and readding it again,because I
created a second nsn group called test group and added 5 people to it and
then sent the same small message and it was delivered so I am thinking there
is something wrong with the group. I'll keep ya posted.

Chris
 
View user's profile Send private message
bf2taz
Newbie
Newbie



Joined: Apr 12, 2006
Posts: 10

PostPosted: Thu Apr 13, 2006 3:41 pm Reply with quote

I deleted the nsn group, readded a group back and assigend all the users to the group. Created a newsletter and sent it to the group and all worked fine.

Thanks
Chris
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Thu Apr 13, 2006 9:06 pm Reply with quote

Ok, all I can say is that I am very relieved to hear it worked this time! You really had me stumped there!

Now I am wondering if your host has any kind of "limiter" on the number of emails that you can send in a day or hour / minute / second????? I have been thinking about adding a configuration setting for a batch delay as well as some other configuration options, but I just have not had time and I have not had many people complain about having such "limiters"... I have only read about them.

By the way, I am going to modify your previous post some to remove some potentially sensitive information that you may not want to be made public.... (PM me if you want to know the what and why.)

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
Display posts from previous:       
Post new topic   Reply to topic

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 4 Hours
 
Forums ©
linear-bunch
linear-bunch