Montego Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic
Author Message
papamike
Newbie
Newbie



Joined: Jun 09, 2011
Posts: 22

PostPosted: Tue Aug 23, 2011 10:38 pm Reply with quote

I just noticed that there are slashes /" in the plain theme for Newsletter, should they be there?
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Wed Aug 24, 2011 8:35 am Reply with quote

papmike,

Can you please be a little more specific? I am not following and cannot find what you are referring to in either Plain_Grey or Plain_Jane templates.

I am also not seeing what you are referring to in any of my sample newsletters off the front of this site.

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
papamike
Newbie
Newbie



Joined: Jun 09, 2011
Posts: 22

PostPosted: Wed Aug 24, 2011 9:08 am Reply with quote

Quote:
<p>Hi, my name is papamike or simply Mike to the small horde of people I call friends and family.
 I am a Network Engineer (PhD) type with over 35 years hovering over both antiques and top of the line computer systems.  My specialty was
both Hex and Decimal programming.  I designed my own compiler and turned my code into true machine language (.exe stuff).  The only language
a computer understands.  I deciphered the electrical signals which pass through the mother board and that make computers operate.</p>
<p> Papa Mike Creations(PMC) has come a long way since way back in 1994.  I can truthfully say that PMC has been on the Internet
continuously since that date.  I have been fortunate enough to have had a long run of successful projects.  My first taste of dealing with
public issues surfaced when I signed on as a Geocities Community leader.  I was responsible for a community of other websites which were listed
under the title of \"The Heartland.\"  I worked diligently on my community, making weekly reports,  creating new methods in hard coding HTML
and internal/external CSS.  After a while and all of a sudden Yahoo purchased Geocities and let it die on the vine.</p>
<p>From my job at Geocities I roamed on over to Yahoo and became a Yahoo expert.  I had spent a lot of time learning new things and 
accumulated quite a following.  But as things happen,
Yahoo decided to shut down the \"Yahoo Expert\" club and I decided that it was probably my time to leave.  From Yahoo I swung a deal with \"Bell
South\" to have a T1 cable trenched into my residence where I could go online and teach.  I opened my server to young people, mostly teenagers,
with a passion for computers and the Internet.  I taught everyone from artist, to a very knowledgeable forums person who was well versed at
administering  the popular (FREE then) IP Board.  I also had people to take on various projects.  In essence we had built and was
managing a pretty good community.  I allocated unlimited space and bandwidth to my \"students.\"
</p>
<p>After quite a while I decided to stop teaching and decided to see what else was out there.  I discovered PHP-Nuke and after going into the
code and looking around I decided I would attempt my hand at creating themes.  So I did, and who knows how many I did create.  My site
wasn\'t hacked and I kept seeing this website on the Internet which stated something to the affect of, you can have a site that\'s as secure as this
one.  Well, one day I registered and started my days in the RavenNuke(tm) community.  I just continued to design themes as I had done using
PHP-Nuke.  And here I am still here today.</p>
<p> </p>
<p>I do have some projects underway:</p>
<p>(1) Papa Mike Creations Customizable Theme (PMCCT) ...   {Almost ready to release ...}</p>
<p>(2)  MySQL database backup and restore utility.  {In testing}</p>
<p>(3)  Compliant W3C XHTML 1.0 Transitional and CSS2.1 themes.  {On going} </p>


This is it as it looks like on my site. You can find this on my site http://papamikecreations.net/modules.php?name=HTML_Newsletter&op=msnl_nls_view&msnl_nid=3 I couldn't get the quote to work properly.


Last edited by papamike on Wed Aug 24, 2011 9:20 am; edited 1 time in total 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Wed Aug 24, 2011 9:18 am Reply with quote

Well, I cannot see the newsletter on your site even though I signed up. Maybe this is a Preview you are showing? If so, try this just to test. Go ahead and send a test newsletter to admin or go ahead and just make it a "ALL site visitors" one so no email is sent. Then we can see what is actually sent/posted... there is a known issue with Preview that I will be working on for 1.4

Also, which template are you using for your newsletter? If no template is being used, then how sure are you that these back-slashes aren't in your original HTML code?

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
papamike
Newbie
Newbie



Joined: Jun 09, 2011
Posts: 22

PostPosted: Wed Aug 24, 2011 11:14 am Reply with quote

I double checked the permissions for that block and it is set for "All Visitors." The code I posted above is the source code for the newsletter, I did remove the META tag though. Using the "No Template" I guess the default option.

I sent another newsletter. On the second one I didn't use any quotes. Maybe that is where I messed up.

Rob, I don't go looking through your modules trying to find stuff wrong. But when I do find something wrong I think it is my duty, as a member of your community, to show you that I care about your mods.

Sorry If I am Aggravating you with this stuff.
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Wed Aug 24, 2011 9:46 pm Reply with quote

papamike,

First of all, I hope that you don't think that I am aggravated. That is not the issue at all. All I am trying to do is get to the bottom of the issue you are seeing only because I'm not seeing it as of yet, except with a known issue with the Preview function.

So, please, no worries and don't take my line of questioning as anything other than just trying to narrow it down.

Ok, now with that behind us, I took your HTML above, removed all the back-slashes and ran it through a test send to admin (looked good). Then I tried this time to do the Preview first, looked good, but when I click the "BACK" button, there are all the back-slashes right there within the body. So, this is the known issue I was talking about. If you go to send this one now, its still got the inserted back-slashes in the body.

So, mystery solved. Its the known issue and is being worked on already with 1.4 version. I intend on delivering this version to the RN team, with this fix, within the next couple of weeks. Smile

Regards,
montego

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
papamike
Newbie
Newbie



Joined: Jun 09, 2011
Posts: 22

PostPosted: Wed Aug 24, 2011 10:24 pm Reply with quote

Can I design themes for it?
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Thu Aug 25, 2011 6:49 am Reply with quote

By the way, good news. I tested this out in my local working copy of 1.4 and I have already fixed this issue! I've picked 1.4 up and laid it down so many times that I had to test to see. Smile

With regards to this:

papamike wrote:
Can I design themes for it?


Absolutely.

However, just want to give you some insight into my road map. My plan is to re-write the template system. While it isn't too difficult to work with right now, I'd really like to be able to view my templates to be viewable in a browser or some kind of "viewer" to where I can see all the containers, their positions on the page, the presentational elements, etc. Right now, one has to build the HTML separately first and once you're good with it, pull out all the relevant pieces into their respective variable assignments into the template.php script. At least that is how I would do it.

So, just fair warning that this will be coming eventually. Problem is, I haven't a clue when. It has been many years since I last made a release so it could be end-of-year, next year, or 2 - 3 years from now.
 
View user's profile Send private message Visit poster's website
Display posts from previous:       
Post new topic   Reply to topic

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 4 Hours
 
Forums ©
linear-bunch
linear-bunch
linear-bunch