Montego Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic
Author Message
zacklk
Newbie
Newbie



Joined: Mar 20, 2010
Posts: 35

PostPosted: Sat Mar 20, 2010 11:01 pm Reply with quote

hey guys im using PHP-Nuke 8.0. i used your ShortLinks hack in my site. problem i have is for a example if i type www.mysite.com/forums.html it works. but in my module menu and everywhere else its still www.mysite.com/modules.php?name=Forums. please help guys. thanks in advance.
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Sun Mar 21, 2010 10:19 am Reply with quote

Is your "module menu" the default block-Modules.php script or something else? If it is something else, then you must create the equivalent of ShortLinks/GTB-block-Modules.php with the proper block script name.

For "everywhere else", see the GTZ-PageTap.php script where you can place any miscellaneous taps that are needed to cover any remaining links that are not produced by a block or a module.

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
zacklk
Newbie
Newbie



Joined: Mar 20, 2010
Posts: 35

PostPosted: Mon Mar 22, 2010 2:09 am Reply with quote

tnx for the reply. im using the default modules menu. i even try the "Sommaire" but nothing works. all the links work fine if i type in the browser manually. for some examples:

http://www.mysite.com/account.html works but in my module block its
http://www.mysite.com/modules.php?name=Your_Account

and
http://www.mysite.com/submit.html works but in modules block its
http://www.mysite.com/modules.php?name=Submit_News

really appreciate any help that you can give me. thanks.
 
View user's profile Send private message
Slackervaara
Newbie
Newbie



Joined: Nov 03, 2007
Posts: 126

PostPosted: Mon Mar 22, 2010 2:37 am Reply with quote

In config.php do you have this:

Code:

$tnsl_bUseShortLinks   = true;  //Setting this to "true" will cause RavenNuke(tm) to shorten the URLs in GoogleTap/GTNG fashion.
$tnsl_bAutoTapBlocks   = true;  //Setting this to "true" will cause RavenNuke(tm) to shorten the URLs automatically for block files.
$tnsl_bAutoTapLinks    = true;  //Setting this to "true" will cause RavenNuke(tm) to search for additional untapped links and attempt to shorten them - could slow down your site
$tnsl_bDebugShortLinks = false;  //Setting this to "true" will cause the ShortLinks function to display debugging information.
 
View user's profile Send private message
zacklk
Newbie
Newbie



Joined: Mar 20, 2010
Posts: 35

PostPosted: Mon Mar 22, 2010 5:13 am Reply with quote

Nop. i have it like this

Code:
$tnsl_bUseShortLinks   = false;  //Setting this to "true" will cause RavenNuke(tm) to shorten the URLs in GoogleTap/GTNG fashion.
$tnsl_bAutoTapBlocks   = false;  //Setting this to "true" will cause RavenNuke(tm) to shorten the URLs automatically for block files.
$tnsl_bAutoTapLinks    = false;  //Setting this to "true" will cause RavenNuke(tm) to search for additional untapped links and attempt to shorten them - could slow down your site
$tnsl_bDebugShortLinks = false;  //Setting this to "true" will cause the ShortLinks function to display debugging information.


And i put it on the top after the <?php
 
View user's profile Send private message
zacklk
Newbie
Newbie



Joined: Mar 20, 2010
Posts: 35

PostPosted: Mon Mar 22, 2010 5:28 am Reply with quote

Great i made the 1st 3 lines "true" and now it works. thanks a lot Slackervaara and you too montego. keep up the good work.
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Mon Mar 22, 2010 8:42 am Reply with quote

I would try setting the third one as false and checking all your links again. This setting can be quite slow. The first two should be all that you need? If not, then something else is still not right.

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
zacklk
Newbie
Newbie



Joined: Mar 20, 2010
Posts: 35

PostPosted: Mon Mar 22, 2010 9:37 am Reply with quote

tnx ya its work even if i put third one to off. i have found one problem in news. in related links there is

More about "Your Topic"
News by "Author Name"

when i click any of these links its comes to a search page which is blank. do u have any ideas why this happening. I'm so sorry to disturb you guys like this. again thank you so much for your help.
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Mon Mar 22, 2010 11:27 am Reply with quote

Is the page really blank, or is there a search box at the top along with search options right below? These links should be changing the search options below the search box. But, then again, this is PHP-Nuke 8.0 which I do not have...

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
zacklk
Newbie
Newbie



Joined: Mar 20, 2010
Posts: 35

PostPosted: Mon Mar 22, 2010 12:00 pm Reply with quote

Ya search box is there. i try the normal search it works fine. and i was able to tap my forum block too. now all that left is my advanced download block. still trying that one. just wanna tell you thank u so much for this wonder full mod.
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Mon Mar 22, 2010 1:45 pm Reply with quote

You are very welcome and I am glad that you are finding it useful. If I can carve out some time this week, I will try testing out these two links with ShortLinks off and see what I end up with. I was thinking these were working fine as it is bringing up the search box with the options set to whatever the link was that you clicked, but I don't recall what these did prior to being tapped...

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
zacklk
Newbie
Newbie



Joined: Mar 20, 2010
Posts: 35

PostPosted: Mon Mar 22, 2010 2:18 pm Reply with quote

thanks a lot. i will wait for that and in the mean time ill try my self to figure it out. thanks.
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Wed Mar 24, 2010 8:19 am Reply with quote

I know that you are on PHP-Nuke 8.0, but I kind of doubt it is any different than my RavenNuke. I just tried these two links with ShortLinks turned off, and they produce the same output as when ShortLinks are on.

What these two links are doing is to modify the search parameters. If you watch the drop downs carefully upon clicking each link separately, you will see the difference.

For example, when I click on the "News by montego" link, I will come to the search page and the Author drop-down will be pre-populated/defaulted to "montego". The intent then is for you to enter in your search text and then only those articles written by user "montego" will be searched for that text.

I believe this is working as designed.

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
zacklk
Newbie
Newbie



Joined: Mar 20, 2010
Posts: 35

PostPosted: Wed Mar 24, 2010 8:37 am Reply with quote

i guess its maybe something to do with my modifications. i mean not with short links. i did lot of other twicks. so ill check it out and post back. thank you for the informations.
 
View user's profile Send private message
Slackervaara
Newbie
Newbie



Joined: Nov 03, 2007
Posts: 126

PostPosted: Thu Mar 25, 2010 11:30 pm Reply with quote

When I suspect Shortlinks to disturb something, I disable it in config.php i.e from true to false and make the test again. If the errors persists then, it is not Shortlinks fault.
 
View user's profile Send private message
Display posts from previous:       
Post new topic   Reply to topic

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 4 Hours
 
Forums ©
linear-bunch