Montego Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic
Author Message
nashwan
Newbie
Newbie



Joined: Dec 01, 2005
Posts: 2

PostPosted: Thu Dec 01, 2005 8:00 pm Reply with quote

when i want to send the newsletter and i choose one style and after then also some forums but i get error just when i choose forums and download ? so in this situation i can just send this newsletter with out news about my forums
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Thu Dec 01, 2005 9:54 pm Reply with quote

nashwan wrote:
when i want to send the newsletter and i choose one style and after then also some forums but i get error just when i choose forums and download ? so in this situation i can just send this newsletter with out news about my forums


Can you please tell me exactly which options you have selected (for example, what template you used) and also what version of Nuke and patch level please.

I just tried both a Preview and Test Admin send for Fancy Content and Plane Jane newsletter templates and choosing just 5 Forum posts and 5 Downloads and it has worked just fine.

Also, please try it once for ONLY forums (no downloads or others) and let me know how that goes.

I need to run the exact same screnario from my site. If I can replicate the issue, I can fix it rather easily. I suspect it is something else within the installation, but let us rule out some things first.

Regards,
montego

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Fri Dec 02, 2005 8:46 am Reply with quote

I need the error message you are getting as well. I should have asked that first! Embarassed

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
nashwan
Newbie
Newbie



Joined: Dec 01, 2005
Posts: 2

PostPosted: Sun Dec 04, 2005 3:41 pm Reply with quote

thx u 1000000 time for the reply my topic honestlly i use phpnuke vesion 7.9 and i have 2 theme also when i change my site to Deepblue i get the same things i mean there is not error text or some things like this i just get this pic what u see here . also i tested with only 5 forums and it is the same it is not working with my forums i really don't know but any ways i like your wonderful modules thx againnnnnnnnnnnnnnnnnn
Image
 
View user's profile Send private message
Guardian
Site Admin
Site Admin



Joined: Jul 18, 2005
Posts: 397

PostPosted: Mon Dec 05, 2005 12:54 pm Reply with quote

Loading please wait..... ?
That looks like it could be an issue with the tinymce editor.
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Mon Dec 05, 2005 4:03 pm Reply with quote

Yeah, I was thinking the same thing... just been too busy to respond. Actually, I was trying to figure out a tactful way to say that I don't support any nuke version above 7.6. Just too many security holes and bugs and someone needs to take a stand. Laughing

nashwan, actually, on the serious side, I really do not know what impact the TinyMCE editor and its implementation into 7.7+ would have on the Newsletter. This is one of those cases where the integration may not behave properly with the module. Unfortunately, I just don't have time to support it right now. Maybe some day when we have a distribution and HTML editor integration that has been done properly.

You are really "playing with fire" using anything above nuke 7.6!

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Mon Dec 19, 2005 7:20 pm Reply with quote

nashwan wrote:
when i want to send the newsletter and i choose one style and after then also some forums but i get error just when i choose forums and download ? so in this situation i can just send this newsletter with out news about my forums


nashwan, did you ever figure out what was wrong with the TinyMCE Editor? Or, did you downgrade to 7.6?

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Fri Jan 27, 2006 8:48 am Reply with quote

nashwan,

The next release of HTML Newsletter (1.3) will have integration to nukeWYSIWYG (http://www.nukeSEO.com). This is currently using FCKEditor, but I believe Kguske is also working on SPAW.

Regards,
montego

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
quietlycrazy
Newbie
Newbie



Joined: May 20, 2006
Posts: 1

PostPosted: Sat May 20, 2006 2:21 pm Reply with quote

Simple solution to the incompatibility with this module and versions above 7.6

Arrow Go to your config.php file in your nuke root directory and turn off the wysiwyg. Then when done sending turn it back on.

Code:
Find:

$nuke_editor = 1;

and change to:
$nuke_editor = 0;


Works well!!!!
 
View user's profile Send private message
Guardian
Site Admin
Site Admin



Joined: Jul 18, 2005
Posts: 397

PostPosted: Sat May 20, 2006 3:25 pm Reply with quote

Hmm interesting, I guess if it was really needed, it would be possible to to check to see if the variable $nuke_editor exists, check the value (1 or 0 ) and then temporarily change the state before restoreing it during the sending process.
Not sure if Montego would want to go to all that trouble considering that nuke 7.6+ is not supported due to the inherent security problems with those versions but it may atleast you give something to think about for your own use and would save you keep ftp'ing your config file
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Sat May 20, 2006 4:19 pm Reply with quote

Actually, if it really IS this easy, I will add this to the next release. Thanks quietlycrazy for the "hint". You will be credited for sure!

The only thing is that I do not have a ton of time to test versions other than what I already certify this on, so if you wouldn't mind being a part of my future beta test (several months away), I sure could use someone more familiar with 7.7 and above.

Thanks again for posting this also for others to benefit from!

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
deaux
Newbie
Newbie



Joined: Sep 28, 2007
Posts: 1

PostPosted: Thu Oct 11, 2007 10:17 am Reply with quote

quietlycrazy....Thanks for the find. I am still learning php nuke (know enough to be dangerous) and this helps out a lot since I am running 7.9

montego....hope you do decide to comeout with newer version. Thanks for a great mod

Twisted Evil Twisted Evil
deaux
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Thu Oct 11, 2007 10:17 pm Reply with quote

Yeah, sorry, the "several months away" has turned into a life-time... Sad Some day...

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
Display posts from previous:       
Post new topic   Reply to topic

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 4 Hours
 
Forums ©
linear-bunch