Montego Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic
Author Message
Alferez
Newbie
Newbie



Joined: Mar 03, 2008
Posts: 1

PostPosted: Wed Apr 16, 2008 2:57 pm Reply with quote

Hello i install Shortlink 1.2.0 in mi web ( www.xsarausuarios.com ). i find a bug of "list of user" and upgrade to 1.2.1 but one bug no resolve.
For example when i have 3 post without read and i read second post automatically marked read first and second.
Have it solution?
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Wed Apr 16, 2008 9:50 pm Reply with quote

Turn off ShortLinks within config.php (or rnconfig.php if using RavenNuke) and see if the behavior is the same. I have never heard of this "bug" before and struggling to understand how ShortLinks could cause that.

Maybe if you could post here the links that your clicking that end up causing the issue. That might help me understand this better.

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
Guardian
Site Admin
Site Admin



Joined: Jul 18, 2005
Posts: 397

PostPosted: Wed Apr 16, 2008 10:27 pm Reply with quote

I think you will find that the behaviour continues even after turning ShortLinks off.
If that is the case then lets narrow it down....
When you are in your forum and you click the background of the forum post row, rather then the displayed link, does it open the forum post?
If you switch to one of the default themes, does the behaviour disappear?

If the answer is yes to either of the above then it is because your theme has a forum template that is using an ja va script onClick event and this is breaking the session, resulting in incorrectly 'read topic' indication.
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Wed Apr 16, 2008 11:10 pm Reply with quote

Guardian, you are a gentleman and a scholar. Sure glad you know phpBB!

BTW, you don't have to worry about writing javascript all as one word. Neither here, nor at Raven's site. Wink

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
Guardian
Site Admin
Site Admin



Joined: Jul 18, 2005
Posts: 397

PostPosted: Thu Apr 17, 2008 4:30 am Reply with quote

I made the discovery by accident as someone asked me to debug this exact same problem.
It took me the best part of a day as I went through the theme line by line because not all his users where seeing this behaviour (some where clicking the text link, others the background) and I couldn't initially reproduce it as I always click the link.
It was only quite late on when the client then mentioned ShortLinks wasn't working when you clicked the background - there is only one reason why htaccess could not be re-writing the exact same url so I looked again and saw the onClick events tucked away.
As it happened, he wasn't too keen on all the forum 'add-ons' so I ended up re-styling fisubice template to match his theme, using his forum buttons etc.
 
View user's profile Send private message
Display posts from previous:       
Post new topic   Reply to topic

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 4 Hours
 
Forums ©
linear-bunchlinear-bunch