Montego Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic
Author Message
pezzer1
Newbie
Newbie



Joined: Nov 26, 2007
Posts: 22

PostPosted: Tue Nov 27, 2007 1:36 pm Reply with quote

I recently installed Shortlinks and it worked great - on a side note, compared to the other mod rewrite apps I've attempted, this is the first one that worked well (and on the first try, too.)

Anyway, I've found one issue that I can't seem to resolve. The random headlines block errors out when one clicks on a topic. The error is as follows:

"Search System Error - your query must be at least 3 characters to be processed, etc. etc. etc"

This error only occurs when Shortlinks is turned on (set to "True") I turned the blocks to "False" with no difference.

In case you're not aware, the random headlines block takes random topics, then makes the link a search query for that topic. It appears that Shortlinks is passing along a blank query instead of using the topic in the search.

For example, it grabs a random topic from the database and displays it, lets say "Topic1" - when one clicks on the link, it queries the database for all topics that match "Topic1" - based on the error, Shortlinks doesn't appear to be passing the string "Topic1" to query, it seems to be passing along a null string.

Without Shortlinks - http://www.***.com/modules.php?name=Search&topic=14

With Shortlinks - http://www.***.com/search-14.html

Anyone have any ideas?
 
View user's profile Send private message
Guardian
Site Admin
Site Admin



Joined: Jul 18, 2005
Posts: 397

PostPosted: Tue Nov 27, 2007 2:14 pm Reply with quote

Is this the standard nuke random headlines block and is the News module the standard nuke News module?
 
View user's profile Send private message
pezzer1
Newbie
Newbie



Joined: Nov 26, 2007
Posts: 22

PostPosted: Tue Nov 27, 2007 2:36 pm Reply with quote

This is a clean install of PHPNuke 8.0 with all standards modules. I have tweaked a little, but this error happened prior to those and I made no changes to the random headlines block (except change the name from "random headlines" to "featured articles.")

Also, I've been playing with the .htaccess file to try to remove the short URLs just for this block (or the search module,) but I haven't had any success yet. It always returns a page not found error (or something like that) when I do this. I'm still messing around with it, though...
 
View user's profile Send private message
pezzer1
Newbie
Newbie



Joined: Nov 26, 2007
Posts: 22

PostPosted: Tue Nov 27, 2007 2:59 pm Reply with quote

Oh yeah - one more thing - I don't think it's really relevant since it handles these differently, but in the same random headlines block, it lists both the topic and a few articles under that topic. The links to the actual articles works fine - it's just the topic link itself.

If worse comes to worse, I'll just remove the topic link completely and leave only the articles themselves in that block, but I would rather not do that if possible.

I just still don't have a good understanding of how mod rewrite works and where in the process these links get shortened and how ShortLinks does this - I still thought that the links worked on the backend just as they normally would, it's just the end page shows the short URLs - Like I said, I just don't understand the process well enough to troubleshoot this myself.
 
View user's profile Send private message
Guardian
Site Admin
Site Admin



Joined: Jul 18, 2005
Posts: 397

PostPosted: Tue Nov 27, 2007 3:17 pm Reply with quote

OK thanks for the info.
I'm not sure I have time to look at this myself as I'm only 2 days away from moving house and still have tons of things to pack but can I assume that 'use shortlinks blocks' is also turned on as well as the general shortlinks settings to True.
A link to your site so we can see the actual links would really help too.
 
View user's profile Send private message
pezzer1
Newbie
Newbie



Joined: Nov 26, 2007
Posts: 22

PostPosted: Tue Nov 27, 2007 3:33 pm Reply with quote

Shortlinks = True
TapBlock = True
AutoTapLinks - False

I set Tapblock to false and taplinks to True (and every combination of both) with no difference. I didn't think to set debug to true - I'll try that and see if it shows anything. (Like I mentioned, when I set everything to False, the block works as it should.)

The site is http://69.5.18.173

It's not in production, so there is nothing real there - there are just random test articles posted. I haven't switched DNS to my new host so that's why it's just an IP as of now.

I don't have articles in every topic, so most of the time, the headline block only shows the topic - as of now, I only have articles in "Health" and "Adventures" so if you refresh enough times, it will show those articles.

Good luck with your move - This mod is 99.9% working perfectly - if this is the only issue I run into, I couldn't be happier. So, this is certainly not urgent in any way. I have plenty of work to do on the site.
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Tue Nov 27, 2007 3:36 pm Reply with quote

If you like for now, just rename (or remove) the GTB-block-Random_Headlines.php file that is for the random headlines.

Since I do not use PHP-Nuke 8.0, would you mind sending me the block file that you are using? Please send to montego {AT} montegoscripts dot com.

Thanks.
 
View user's profile Send private message Visit poster's website
pezzer1
Newbie
Newbie



Joined: Nov 26, 2007
Posts: 22

PostPosted: Tue Nov 27, 2007 4:11 pm Reply with quote

I have sent the file -

I am very confused - I renamed the GTB-block-Random_Headlines.php file and that didn't make any difference - I then renamed the GTB-Search.php and that didn't make any difference.

If you go back to the site, I have debug turned on and it shows the random headline mod is not loaded, but it still has a short link.

That's very weird. Maybe its some sort of cache issue? I'll clear all of that out and maybe that will fix it -

I know it's more of a workaround than a fix, but if renaming that GTB-headline file works, then this will take care of my issue.
 
View user's profile Send private message
pezzer1
Newbie
Newbie



Joined: Nov 26, 2007
Posts: 22

PostPosted: Tue Nov 27, 2007 4:39 pm Reply with quote

As an update - I've been messing around with this and I renamed the GT-News.php file and that fixes the Random Headlines link issue, but of course, as a side effect, it removes all of the short links in the news module, which is why I need this in the first place.

It appears the random headline block is embedding itself into the news module code?

I wish I knew how this worked better so I could make better educated tweaks... But that appears to be why it doesn't work when I renamed the GTB-block-Random_Headlines.php file.

Again, though - this isn't a huge issue, just one that has me puzzled.
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Wed Nov 28, 2007 7:30 am Reply with quote

No, been looking at the block you sent me, and it is looking fine. However, I think 8.0 must have an issue in the search module. I just tested this again with ShortLinks true/false with RavenNuke and it works just fine.

But, based on the block file, which is identical in its links to RavenNuke, ShortLinks by itself is not the problem. I suspect that FB modified Search in the higher nukes but forgot to change his Random Headlines block to match his changes to Search.

Not sure when I'll get to digging into 8.0 because I do not typically work with nukes above 7.6 due to all their security issues. I have a feeling that FB changed from using the topic id to some kind of topic title maybe...

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
pezzer1
Newbie
Newbie



Joined: Nov 26, 2007
Posts: 22

PostPosted: Wed Nov 28, 2007 10:31 am Reply with quote

So Nuke 7.6 is more secure than 8.0? Great - I will assume there is no way to downgrade. Maybe I can gather the strength to kill my 8.0 installation and do a clean install of 7.6.

Thanks for your help on this...
 
View user's profile Send private message
Guardian
Site Admin
Site Admin



Joined: Jul 18, 2005
Posts: 397

PostPosted: Wed Nov 28, 2007 11:45 am Reply with quote

Use RavenNuke it is based on 7.6 but with a huge number of bug fixes, security enhancements and speed improvements Wink
 
View user's profile Send private message
pezzer1
Newbie
Newbie



Joined: Nov 26, 2007
Posts: 22

PostPosted: Wed Nov 28, 2007 4:12 pm Reply with quote

I did in fact install RavenNuke and though there is still a LOT of tweaking in general to do to the site, this did fix the issue.

It's nice that Shortlinks is built in.
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Wed Nov 28, 2007 8:25 pm Reply with quote

Ah, this "warms my heart" to see another RN "convert". LOL. It is ALL I run these days. We cannot express enough just how many bug fixes we have made as well as almost 100% XHTML 1.0 Transitional compliant (at least where it counts - 2.20.00 release is just around the corner too).
 
View user's profile Send private message Visit poster's website
Display posts from previous:       
Post new topic   Reply to topic

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 4 Hours
 
Forums ©
linear-bunch
linear-bunchlinear-bunch