Montego Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic
Author Message
Eduardo
Newbie
Newbie



Joined: Oct 30, 2007
Posts: 16

PostPosted: Tue Oct 30, 2007 3:41 pm Reply with quote

I have a problem to install the NSN GR Downloads.
The PHPNUKE version is RavenNuke_v2.10.01.
When I go to the first installation in the page:

http://www.mysite.it/nsngd.php

I receive a blank page, so it is impossible to install the database tables:

- nuke_nsngd_accesses
- nuke_nsngd_categories
- nuke_nsngd_config
- nuke_nsngd_downloads
- nuke_nsngd_extensions
- nuke_nsngd_mods
- nuke_nsngd_new

Where is the problem?

Many thanks in advance.

Filippo Eduardo Araniti

http://www.guitaronline.it
http://www.ibmi.it
 
View user's profile Send private message
Guardian
Site Admin
Site Admin



Joined: Jul 18, 2005
Posts: 397

PostPosted: Tue Oct 30, 2007 7:47 pm Reply with quote

Are you logged in as the site admin?
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Tue Oct 30, 2007 11:16 pm Reply with quote

Guardian's question is very important, but also would like to know if you have nukeFEED installed. The answers to these TWO questions will dictate our next response.

Thanks.

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
Eduardo
Newbie
Newbie



Joined: Oct 30, 2007
Posts: 16

PostPosted: Wed Oct 31, 2007 4:03 am Reply with quote

Guardian wrote:
Are you logged in as the site admin?


I tested again the tables installation with the log in as site admin.

The result is a blank page.
 
View user's profile Send private message
Eduardo
Newbie
Newbie



Joined: Oct 30, 2007
Posts: 16

PostPosted: Wed Oct 31, 2007 4:11 am Reply with quote

montego wrote:
but also would like to know if you have nukeFEED installed


I have not nukeFEED installed.

In the nsn instructions (Readme) I read:

2. Introduction and Requirements
--------------------------------
- It requires PHP-Nuke 7.5 thru 7.6 & NSN Groups 1.5.0+ plus Patched 2.9+ installed.
- NSN GR Downloads DOES NOT use the old Downloads files.


Why the script not install the tables?

What I must do?

Really need I install first nukeFEED?
 
View user's profile Send private message
Guardian
Site Admin
Site Admin



Joined: Jul 18, 2005
Posts: 397

PostPosted: Wed Oct 31, 2007 4:21 am Reply with quote

No you do not have to have nukeFEED installed to use NSN GR Downloads or install it.

I think Montego is aware of some compatibility problem with nukeFEED and NSN GR Downloads - I think the post is on this site somewhere but clearly this is not the problem if you do not have it installed.

To be honest I'm scratching my head a little as I have never had a problem installing NSN GR Downloads but I do wish it had a sql file for cases like this where the installer isnt working.
I'm sure Montego will have the answer for you though Wink
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Wed Oct 31, 2007 9:00 am Reply with quote

Unfortunately I am going to have to create a new environment with 2.10.00 to test this on as it has been years since I have had to run the installer. I will not have time, I don't think, this week during the week so will try and do so this weekend and get back to you.

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
Eduardo
Newbie
Newbie



Joined: Oct 30, 2007
Posts: 16

PostPosted: Wed Oct 31, 2007 11:28 am Reply with quote

Thank you very much.
 
View user's profile Send private message
Eduardo
Newbie
Newbie



Joined: Oct 30, 2007
Posts: 16

PostPosted: Mon Nov 05, 2007 5:33 am Reply with quote

In the Credits/Contributions For RavenNukev2.10.01 I read:

NSN Groups: Bob Marion (with fixes by Raven and Montego).

Do you think that your fixes cause the bug in the tables installations?
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Mon Nov 05, 2007 8:08 am Reply with quote

Absolutely not. We made no database table changes. Just fixed core code in NSN Groups only.

Sorry. Did not get a change to run through an install and I am traveling on business this week. Life just has me too busy these days. Sad

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
Guardian
Site Admin
Site Admin



Joined: Jul 18, 2005
Posts: 397

PostPosted: Mon Nov 05, 2007 9:12 am Reply with quote

I do not have time either at the moment to install and debug.
However, if it helps you, here is a link to a plain text file with the table structure you can import using phpmyadmin from your hosting providers control panel.
www.code-authors.com/nsngd.txt
 
View user's profile Send private message
Eduardo
Newbie
Newbie



Joined: Oct 30, 2007
Posts: 16

PostPosted: Mon Nov 05, 2007 10:30 am Reply with quote

When I am installing the tables with phpmyadmin the server gives me the following error:

Quote:
Errore

query SQL:

CREATE TABLE `nuke_nsngd_accesses` (
`username` varchar( 60 ) NOT NULL default '',
`downloads` int( 11 ) NOT NULL default '0',
`uploads` int( 11 ) NOT NULL default '0',
PRIMARY KEY ( `username` )
) ENGINE = MYISAM DEFAULT CHARSET = latin1;

Messaggio di MySQL: Documentazione
#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=latin1' at line 6


Is this the solution of the problem?

Please see the php info of my server at the following link:

<<link removed by admin - NEVER leave this info exposed!>>
 
View user's profile Send private message
Guardian
Site Admin
Site Admin



Joined: Jul 18, 2005
Posts: 397

PostPosted: Mon Nov 05, 2007 12:20 pm Reply with quote

I have amended the data in the txt file.
Please try it again.
 
View user's profile Send private message
Eduardo
Newbie
Newbie



Joined: Oct 30, 2007
Posts: 16

PostPosted: Mon Nov 05, 2007 4:17 pm Reply with quote

Well! I have installed the tables by phpmyadmin.

When I go in the admin groups I receive a blank page.

For help you to help me I inform you that under the admin image of the group module there is: _GR_ADMGRP

Also, when I go, as user, in the Groups module I see:

Public Groups

_GR_GRPNAME _GR_NUMUSERS _GR_LIMIT
There are no public groups in the database.

I think that something does not work.
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Mon Nov 05, 2007 5:36 pm Reply with quote

These errors seem to me to imply that even your RavenNuke 2.10.01 installation is not complete. You should focus first on getting that corrected and I would recommend posting those questions are Raven's site.

In addition, you cannot just create the GR Downloads tables as there is also the process for copying over your existing download data from the old tables (if you have data I suppose).

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
Display posts from previous:       
Post new topic   Reply to topic

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 4 Hours
 
Forums ©
linear-bunch
linear-bunch