Montego Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic
Author Message
ddog241
Newbie
Newbie



Joined: May 23, 2007
Posts: 13

PostPosted: Wed May 23, 2007 7:54 pm Reply with quote

ok lets try this again Laughing

i installed the gt and worked great, the 1 problem i did find is if you run a dual downloads mod like i do. SL dont seem to like it i have both nukestyles edl and nsn gd
nukestyles is downloads
nsngd was downloads2 ..i had to change the name of it incase a user wanted to get into the freeware section, so now downloads2 is now just FreeWare, now after looking at this and that. i figured to get SL to work on the newly renamed nsngd FreeWare so i thought to make it work all i would really need to do is rename downloads to freeware
like below
Code:
 Downloads.html  to FreeWare.html

downloads.html2 to modules.php?name=FreeWare



now with the modules.php?name=FreeWare it works fine
but after editing the sl code to match it dont work, i know i went wrong somewhere just dont know where lol its my 1st time playing with the googletap shortlinks

any ideas
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Wed May 23, 2007 10:29 pm Reply with quote

Well, first of all, great job in analyzing this and coming up with a different tool called FreeWare. Key question: without the GT-FreeWare.php file in the ShortLinks directory, have you tried each and every link within the FreeWare module and each one works just fine? That is number 1 priority to ensure all is working there first.

Now, secondly, I am not sure which part of the SL is not working? Are the links not getting shortened? Or, are they getting shortened, but when you click them, you get a 404 Not Found error in the browser? (I have other threads which discuss that issue BTW.)

One other question: do other shortened links from other modules work fine?
 
View user's profile Send private message Visit poster's website
ddog241
Newbie
Newbie



Joined: May 23, 2007
Posts: 13

PostPosted: Thu May 24, 2007 1:39 pm Reply with quote

yes the FreeWare "nsndlownload rename" works just fine
just no sl
the sl dose work fine everywhere else
Download.html Account.html Top.html ect
i renamed the GT-Download "for nsn dl" to GT-FreeWare and redid a little code instead of download.html changed to FreeWare.html ect since i never messed with sl untill yesterday im assuming i ether messed something up or i forgot to mod a line of code somewhere
so SL works everywhere else exept for my freeware

i thought it was kind of odd that everything works but dont work lol this can be confusing, i hope im explaining it all right
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Thu May 24, 2007 2:21 pm Reply with quote

No, sorry, this confuses me:

Quote:

i thought it was kind of odd that everything works but dont work


I will assume that the issue you are having is that the links are being shortened within FreeWare, but when you click on them, you are getting the 404 error in the browser.

You also have to make the corresponding section of RewriteRules in the .htaccess file to match what you did in GT-FreeWare.php (but in the reverse). Use the existing Downloads as an example.

In addition, within GTB-Modules.php, you need to have an entry in there for FreeWare.html.

Hope this helps.

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
ddog241
Newbie
Newbie



Joined: May 23, 2007
Posts: 13

PostPosted: Thu May 24, 2007 5:51 pm Reply with quote

ahhh i left out the gtb-modules lol,

the sl wasnt working on the freeware but the module wass working just showing the long url
modules.php ect

but now you tell me about the gtb-modules entry i think that is what i left out, ill let you know if i still lhave probs after editing the modules.php

and sorry for b'in so confusing lol, i run around 1/2 confused most the time so im used to it lol
 
View user's profile Send private message
ddog241
Newbie
Newbie



Joined: May 23, 2007
Posts: 13

PostPosted: Thu May 24, 2007 6:11 pm Reply with quote

ok found the prob i forgot to edit the gtb-modules now it works just fine, i kinda thought i forgot something
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1399

PostPosted: Thu May 24, 2007 10:44 pm Reply with quote

Very good. Glad you are all fixed up. Great job!
 
View user's profile Send private message Visit poster's website
Display posts from previous:       
Post new topic   Reply to topic

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 4 Hours
 
Forums ©
linear-bunchlinear-bunch