Montego Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic
Author Message
Slackervaara
Newbie
Newbie



Joined: Nov 03, 2007
Posts: 127

PostPosted: Sat Apr 05, 2008 2:23 am Reply with quote

Hi all,

I have used a slightly modified Deepblue theme with different logo.gif and logo-graphic.gifs compared with original. I also have changed the buttons a little. It have worked very well for many newsletters that I have sent, but yesterday the Top10 button was placed under the Home button and not to the right as usual. I have not made any changes to template.php at all during this period. Earlier the Top10 button was not clickable and did not lead to Top10 of the site, but now it does.


Last edited by Slackervaara on Sat Aug 16, 2008 3:20 am; edited 1 time in total 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1393

PostPosted: Sat Apr 05, 2008 7:32 am Reply with quote

Well, something has changed somewhere. I believe everything is self-contained within that templates directory for DeepBlue, so check the dates on the files there.

Any other server changes that you are aware of? Did you move servers? Anything?

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
Slackervaara
Newbie
Newbie



Joined: Nov 03, 2007
Posts: 127

PostPosted: Sun Apr 06, 2008 2:19 am Reply with quote

No nothing have been changed at all on the server and I have checked file dates in the templates folder too.

I have, however, to get it to work by using this code for the Top10 button:
<img alt=\"\" border=\"0\" src=\"{SITEURL}/modules/HTML_Newsletter/templates/{TEMPLATENAME}/top10.gif\" width=\"140\" height=\"18\"></td>
 
View user's profile Send private message
Guardian
Site Admin
Site Admin



Joined: Jul 18, 2005
Posts: 401

PostPosted: Sun Apr 06, 2008 4:32 am Reply with quote

It looks to me that something has caused that last image to wrap to a new line but the original template code seems to indicate they should all be inline.
It might be worth adding up the image widths, plus any border widths to see if the total is the same as the table width. As this theme has a fixed width, if the total image (plus borders) width is greater than the fixed table width, it would cause that sort of wrapping.
 
View user's profile Send private message
Slackervaara
Newbie
Newbie



Joined: Nov 03, 2007
Posts: 127

PostPosted: Mon Apr 07, 2008 2:30 am Reply with quote

The reason why I made the change was that originally when the Top10 button was in correct position it was not clickable and not working as a link. My thought was if I change the code so Top10 is not clickable and remove the link, it should work again and it did.

I have looked in WinMerge in the source code for a identical newsletter that is working and not working and here is the difference in the source:

height="18"></a><a hr
ef="http://www.viska.se/modules.php?name=Top"><img

height="18"><
/a><a href="http://www.viska.se/modules.php?name=Top"><img
 
View user's profile Send private message
Guardian
Site Admin
Site Admin



Joined: Jul 18, 2005
Posts: 401

PostPosted: Mon Apr 07, 2008 3:39 am Reply with quote

Looks like the first closing /a tag has wrapped onto a new line which wouls break the link (your second example).
 
View user's profile Send private message
Susann
Newbie
Newbie



Joined: Jan 04, 2007
Posts: 61
Location: Germany

PostPosted: Mon Apr 07, 2008 1:37 pm Reply with quote

I know this issue very well its like a dejavu because I had the same problem with my multilingual site. I had my own buttons there and size but somehow this issue didn´t go away whenever I switched over to the english part of my German website.
This is a known issue in theme Deepblue.

Good luck !
 
View user's profile Send private message Visit poster's website
Display posts from previous:       
Post new topic   Reply to topic

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 4 Hours
 
Forums ©
linear-bunch