Montego Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic
Author Message
Crusader_of_Melnibone
Newbie
Newbie



Joined: Mar 10, 2006
Posts: 6

PostPosted: Fri Mar 10, 2006 11:49 pm Reply with quote

I got 7.4 patched. I installed HTML Newsletter 1.2, it partially worked, being able only to send 'no template' emails. Anyway, searching for help I noticed about 1.3 version, so I followed every step to update it.

(1)The SQL error always being displayed is this:
Code:
ENCOUNTERED ERROR IN SQL: Unknown column 'admins' in 'field list'
SQL = SELECT `title`, `admins` FROM `nuke_modules` WHERE `title`='HTML_Newsletter'


(2)While trying to send a test letter to the admin, and having tried all the options available, there is no way I can send it. The only thing I get is a blank page. Nothing else.

I need a help here to make this work, as it's my community's birthday today and a chance to make lots of changes in the site.

(3)Btw, the Newsletter's admin icon seems that it hasn't been defined as it's called "_HNLNAME" and it links to http://.../admin.php?op=HNLAdmin which of course leads to nowhere, so in order to get to the admin config, I write the address manually.
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1393

PostPosted: Sat Mar 11, 2006 8:18 am Reply with quote

I am working on this. The solution to the admin icon not showing up is as follows:

=== OPEN ===

admin/links/links.HTML_Newsletter.php

=== FIND ===

Code:
if ( ( $radminsuper == 1 ) OR ( $radminnewsletter == 1 ) ) {

   if ( !@file_exists( "modules/News/admin/index.php" ) ) {

    adminmenu( $admin_file.".php?op=HNLAdmin", "". _HNLNAME ."", "HTMLnl.png" );

  }

}


=== REPLACE WITH ===

Code:
if ( ( $radminsuper == 1 ) OR ( $radminnewsletter == 1 ) ) {

   if ( !@file_exists( "modules/News/admin/index.php" ) ) {

    adminmenu( $admin_file.".php?op=msnl_admin", "". _MSNL_COM_LAB_MODULENAME ."", "HTMLnl.gif" );

  }

}


================

Now, this isn't going to solve the SQL error issue and the subsequent problems that is causing. I thought I had this tested on 7.4, so sorry for these issues! I am working on a fix now, but no guarantees on "today".

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
Crusader_of_Melnibone
Newbie
Newbie



Joined: Mar 10, 2006
Posts: 6

PostPosted: Sat Mar 11, 2006 12:39 pm Reply with quote

Thanx for the reply and the link fix.

I'll be waiting for the fix. If you need anything from me, I'll be happy to provide it.
In the meantime, if I could just find a way to use a simple html newsletter, even if that means reverting to an old version - provided it works, I'd do it.
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1393

PostPosted: Sat Mar 11, 2006 1:53 pm Reply with quote

I have never had anyone tell me that 1.2 does not work on 7.4. If you are careful in reverting back (i.e., getting the right files in the right places), you should be 'ok'?

Also, if you use NSN Groups or RavenNuke76 v2.x, you can use the NSN Groups admin tool to send a quick-and-dirty HTML email.

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1393

PostPosted: Sun Mar 12, 2006 4:52 pm Reply with quote

I am very close to having this QA tested and deployed. Should be so before the end of the day. I needed to rope a few other bugs to make it an official release.

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
Dawg
Newbie
Newbie



Joined: Mar 15, 2006
Posts: 12

PostPosted: Wed Mar 15, 2006 4:44 pm Reply with quote

montego,
I have the same issue. If you need to Q and A'ed shoot it to me and I will give it the once over.

Dawg
 
View user's profile Send private message
Crusader_of_Melnibone
Newbie
Newbie



Joined: Mar 10, 2006
Posts: 6

PostPosted: Wed Mar 15, 2006 5:22 pm Reply with quote

Hey Dawg,
Glad to hear I was not the only one.

In the past few days, I've been testing the module with Montego and we've managed to make the newsletter working. Not all features work, but it's satisfying enough for me to go on, even if we can't complete the debugging.

But I won't tell you anything else, Montego is the responsible to do the honors, and I guess he's been busy to make this fix flawless before he decides to release it in public. All I wanted was to assure you that the case is far from lost Wink

Take care Wink
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1393

PostPosted: Wed Mar 15, 2006 7:23 pm Reply with quote

Let me just tell that I LOVE NSN Groups! Dawg, you are now one of two people who can download the patch. I cannot figure out why Crusader is having issues when we elect to include Forum posts and/or Reviews. If you could let me know how this works within your installation I would be indebted to you.

This should only be affecting nuke 7.4 and older!

Thanks!

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
Crusader_of_Melnibone
Newbie
Newbie



Joined: Mar 10, 2006
Posts: 6

PostPosted: Wed Mar 15, 2006 9:07 pm Reply with quote

Yeah, I guess NSN Groups and everything by NSN is great, and surely it's useful to developers sites, I doubt it'll come in handy to someone like me I guess Wink Anyway, I've just spent 8 hours integrating a gallery module and my mind's in total chaos, if you'll excuse me Shocked

Btw, Montego, funny you never mentioned it, I just saw a similar problem to mine, actually it sounds exactly the same
http://montegoscripts.com/ftopict-42.html
and it says "resolved". I really need to find out *how*. Razz
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1393

PostPosted: Wed Mar 15, 2006 9:16 pm Reply with quote

The issue in that post was related to the date formatting routine, which I mentioned to you in one of our PM's. Due to Persian being right-to-left and is "script" in form, he had to modify the base phpBB date format routine to work right on his site. He essentially had to use the same for the HNL.

I thought, though, that your Reviews module and Forums were working properly for you? I also validated that your phpBB create_date() function was exactly what I had, so I assumed that would not be it. However, the more I am looking at this, the more I believe it may still be date format related, I just don't know how to fix it!

I am going to see what Dawg comes up with and then maybe look at it again. I'm "stumped".

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
Dawg
Newbie
Newbie



Joined: Mar 15, 2006
Posts: 12

PostPosted: Wed Mar 15, 2006 9:54 pm Reply with quote

montego

I just overwrote the old files....and ran the update script turned Debugging on...in the script and in config.php. Ran through configure....Made a test E-Mail for admin only....hit send....Came back to a Blank admin.php.

More to come....

If you are going to be around tonight....We can work this out. I also have a running team speak server if you would like access.

Dawg
 
View user's profile Send private message
Dawg
Newbie
Newbie



Joined: Mar 15, 2006
Posts: 12

PostPosted: Wed Mar 15, 2006 10:01 pm Reply with quote

I sent you a PM with the Error Output....

Dawg
 
View user's profile Send private message
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1393

PostPosted: Wed Mar 15, 2006 10:07 pm Reply with quote

Sorry, saw your PM before I saw the above. What version of nuke of you running this on and I sure hope its 2.9 patched or greater Wink.

This issue was reported on 7.4. I had forgotten to modify my old nuke-root/admin/case and link files to have all the case entries in it. I had also forgotten that I needed to do the admin check differently for pre 7.5. This was fixed in the patch. In fact, Crusader is able to get his email sends, but just not with Reviews and Forums.

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
montego
Site Admin/Owner
Site Admin/Owner



Joined: Feb 12, 2005
Posts: 1393

PostPosted: Wed Mar 15, 2006 10:14 pm Reply with quote

I appologize guys, but I am just too tired to continue on tonight. I have come down with a flu / cold bug today and feel like you know what. I need to go to bed.

Sorry, I'll try to look at this more tomorrow. Anything you find, please do not hesitate to post here or PM or email me and I'll sort through it in the AM.

Cheers.

_________________
“To err is human, but when the eraser wears out ahead of the pencil, you’re overdoing it.”
-- Josh Jenkins 
View user's profile Send private message Visit poster's website
Dawg
Newbie
Newbie



Joined: Mar 15, 2006
Posts: 12

PostPosted: Wed Mar 15, 2006 11:03 pm Reply with quote

I am on 7.2 with 3.1 patch. No NSN anything. If you want to look at it...I will give you access No Problem.

I will send my Contact info vie PM.

Dave
 
View user's profile Send private message
Display posts from previous:       
Post new topic   Reply to topic

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 4 Hours
 
Forums ©
linear-bunch
linear-bunch
linear-bunch